Denna sida har översatts med AI och maskininlärning.

(Pocket-lint) - Det faktum att Apple driver en uppdatering till iOS är inte särskilt nyhetsvärd, att det gör det för äldre iPhones och iPads från 2012 och uppåt är något helt annat.

Det finns gott om Apple-enheter där ute som inte kan köra iOS 12. Många kör inte ens iOS 11, men Apple har inte gett upp dem ännu.

Faktum är att en ny patch skjuts till alla enheter från iPhone 4s / original iPad mini och högre. Det fixar ett datum- och tidsproblem som annars påverkar GPS-platsfunktionerna i dessa telefoner och surfplattor negativt.

GPS-tidsutrullningsfrågan har påverkat prylar från många tillverkare och trädde i kraft den 6 april. Emellertid kommer Apple-enheter inte att påverkas förrän 3 november så plåstren har släppts på mycket tid.

LG avslutar telefonbiz, Sonos Roam granskas och mer - Pocket-lint Podcast 98

GPS kräver kräver en exakt avläsning av tid och datum för att fungera effektivt och omvandlar dem till ett 10-bitars veckonummer. Ändå innebär en återställning av det 10-bitars veckonummer som förfaller i år att tekniken inte kan hålla ett exakt antal efter återställningsdatumet (i Apples fall i november). Därav lappen.

Du kommer att veta om din enhet har korrigerats om din iPhone 4s och mobilversionerna av första generationens iPad mini, iPad 2 och tredje generationens iPad nu finns på iOS 9.3.6.

Om du har en iPhone 5 eller iPad fjärde generationen med mobil bör du nu vara på iOS 10.3.4.

Skriva av Rik Henderson.