Deze pagina is vertaald met behulp van AI en machine learning.

(Pocket-lint) - Het feit dat Apple een update naar iOS pusht, is niet bijzonder nieuwswaardig, dat het dit doet voor oudere iPhones en iPads vanaf 2012 en hoger is iets heel anders.

Er zijn genoeg Apple-apparaten die iOS 12 niet kunnen draaien. Veel zullen zelfs iOS 11 niet draaien, maar Apple heeft ze nog niet opgegeven.

Inderdaad, er wordt een nieuwe patch gepusht naar alle apparaten vanaf de iPhone 4s / originele iPad mini en hoger. Het lost een datum- en tijdprobleem op dat anders een negatieve invloed zou hebben op de GPS-locatiemogelijkheden van die telefoons en tablets.

Het probleem met de uitrol van de GPS-tijd heeft invloed gehad op gadgets van veel fabrikanten en trad in werking vanaf 6 april. Apple-apparaten worden echter pas op 3 november getroffen, dus de patches zijn ruim op tijd uitgebracht.

GPS vereist een nauwkeurige tijd- en datumuitlezing om effectief te werken en converteert ze naar een 10-bits weeknummer. Maar een reset van het 10-bits weeknummer dat dit jaar verschuldigd is, betekent dat de techneut geen nauwkeurige telling kan bijhouden na de resetdatum (in november, in het geval van Apple). Vandaar de patch.

U weet of uw apparaat is gecorrigeerd als uw iPhone 4s en de mobiele versies van de 1e generatie iPad mini, iPad 2 en 3e generatie iPad nu op iOS 9.3.6 staan.

Als je een iPhone 5 of iPad 4e generatie met mobiel netwerk hebt, zou je nu iOS 10.3.4 moeten gebruiken.

Geschreven door Rik Henderson.