Adobe warns of Flash and Reader "vulnerability"

Back in April, when Steve Jobs penned his now infamous open letter titled, "Thoughts on Flash" he accused the software of not being entirely secure.

And it looks as if the Apple CEO has been proved correct, as Adobe itself has issued a warning stating that "a critical vulnerability exists in Adobe Flash Player", and other Adobe software.

The affected software versions are: Adobe Flash Player 10.1.85.3, and earlier versions for Windows; Macintosh, Linux and Solaris operating systems; Adobe Flash Player 10.1.95.2, and earlier for Android; Adobe Reader 9.4, and earlier 9.x versions for Windows, Macintosh and UNIX, and Adobe Acrobat 9.4 and earlier 9.x versions for Windows and Macintosh.

The vulnerability may cause your system to crash and could "potentially allow an attacker to take control of the affected system".

Adobe is promising an update to the software by 9 November to sort the issue.

Now, we know that Apple hasn't got a perfect record for all things security, but the fact that the main vulnerability that led to the initial jailbreaking of iOS 4 was through a PDF exploit, combined with Adobe's own admission of flaws within its software platforms will no doubt mean that there are some people with very smug faces sitting in their offices in Cupertino right now.