Google dropping Internet Explorer 6 support

Google has warned that from 1 March, users may find that some older browsers no longer work with its Google Docs and Google Sites products. The search company named IE6 in particular as a target.

Google says: "Many other companies have already stopped supporting older browsers like Internet Explorer 6.0 as well as browsers that are not supported by their own manufacturers. We’re also going to begin phasing out our support, starting with Google Docs and Google Sites. As a result you may find that from 1 March key functionality within these products -- as well as new Docs and Sites features -- won’t work properly in older browsers".

The 8-year-old browser, which was launched in 2001 but replaced in October 2006 by IE7, has already been the target of a co-ordinated campaign by more than 70 companies, including Google's own YouTube. Microsoft, the browser's creator, has even offered to donate $1.15 to charity for every person that ditches the ancient software. Even the French and German governments have warned against IE6, but the British government has so far refused to upgrade.

Google adds: "The web has evolved in the last ten years, from simple text pages to rich, interactive applications including video and voice. Unfortunately, very old browsers cannot run many of these new features effectively. So to help ensure your business can use the latest, most advanced web apps, we encourage you to update your browsers as soon as possible".

Google recommends IE7+, Firefox 3+, Chrome 4+ and Safari 3+ for upgraders. You might want to look at Opera 10+, too. Are you still running IE6? Are you resisting the upgrade, or are you stuck with it by an IT department? Let us know in the comments.



>